Battle.net: games don't launch

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
mdw2
Level 2
Level 2
Posts: 20
Joined: Wed Jun 21, 2017 1:07 pm

Battle.net: games don't launch

Post by mdw2 » Wed Jan 09, 2019 1:43 pm

Hi guys,
I upgraded to Linux Mint 19 a while back (I'm currently on 19.1) and ever since that I've been having issues launching some games on the Battle.net Launcher. Specifically, the games Overwatch and World Of Warcraft. I use the currently latest version of wine, wine-4.0-rc5.
After I launch Battle.net with the commands

Code: Select all

cd Battle.net/drive_c/Program\ Files\ \(x86\)/Battle.net/
export WINEPREFIX="/home/marvin/Battle.net"
wine start Battle.net\ Launcher.exe 
I receive many 'fixme' error messages in the console and actual one error message:
0037:err:ole:CoCreateInstanceEx apartment not initialised
After clicking PLAY for Overwatch, i get this error:
017e:err:seh:setup_exception stack overflow 2528 bytes in thread 017e eip 000000007bc99559 esp 0000000000140c30 stack 0x140000-0x141000-0x240000
The launcher displays "Game is running" instead of "Play" for a few seconds before switching back to "Play" and the game .exe appears on htop for that time but disappears again. No application launches.

After clicking PLAY for World Of Warcraft, i get this error:
01ba:err:seh:setup_exception stack overflow 1776 bytes in thread 01ba eip 000000007bc99559 esp 0000000000140f20 stack 0x140000-0x141000-0x240000
Here an application technically starts and fully appears on htop but the app does not actually load, not even a loading screen.
I assume that the errors are not directly connected. I have already reinstalled the launcher to no success.

I know this isn't much to go on but I hope that someone can help me with this.

User avatar
DarkShadow44
Level 7
Level 7
Posts: 920
Joined: Tue Nov 22, 2016 5:39 pm

Re: Battle.net: games don't launch

Post by DarkShadow44 » Thu Jan 10, 2019 7:06 am

What you quote are two crashes. Did you update wine during the changes? If so, does using an older wine version help?

User avatar
Bob Wya
Level 12
Level 12
Posts: 2764
Joined: Sat Oct 16, 2010 7:40 pm
Location: Cambridge
Contact:

Re: Battle.net: games don't launch

Post by Bob Wya » Thu Jan 10, 2019 7:42 am

@mdw2

See: WineHQ AppDB: Overwatch / Current Version.

There are a number of bugs, filed against Overwatch, that are marked STAGED.
So you'll want to retest the game with Wine Staging 4.0-rc5.

Bob

Locked