Debug Error: WinMor

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
MythX
Level 1
Level 1
Posts: 8
Joined: Sun Dec 30, 2018 10:31 am

Debug Error: WinMor

Post by MythX » Sun Dec 30, 2018 10:49 am

Using PlayOnLinux: 4.2.12
Wine: 3.20 x86
Linux: Ubuntu 18.04 x64

I've installed WinMor. (https://github.com/la5nta/pat/wiki/WINMOR-TNC). It runs, but crashes when I do one of 2 things. If I attempt to open the configuration page, and if I hit it with Pat (https://getpat.io/). It opens a tcp listener on port 8500. Once I connect to it from my Pat client, it responds by the following. In fact, in both cases, I get the same errors.

Additional info. I attempted to use PlayOnLinux to install dotnet 2, but there seems to be an issue with loading the MS core fonts and it hangs. Instead, I downloaded .NET Framework from Microsoft and copied the fonts over manually. I suspect this is the cause of my issue, I just don't know how to proceed.

Code: Select all

Running wine-3.20 WINMOR TNC.exe (Working directory : /home/user/wl)
0022:err:module:load_builtin_dll failed to load .so lib for builtin L"winebus.sys": libudev.so.0: cannot open shared object file: No such file or directory
0022:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\WineBus": c0000142
0014:err:service:process_send_command service protocol error - failed to write pipe!
000f:fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 1114
0009:err:mscoree:LoadLibraryShim error reading registry key for installroot

#### Everything above this line is prior to triggering the error
#### Everything below happens once I trigger the error.

0009:fixme:gdiplus:GdipGetLineSpacing ignoring style
0009:fixme:gdiplus:GdipGetLineSpacing ignoring style
0009:fixme:gdiplus:GdipGetLineSpacing ignoring style
0009:fixme:gdiplus:GdipGetLineSpacing ignoring style
0009:fixme:gdiplus:GdipGetLineSpacing ignoring style
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
you are registering twice the same counter address
* Assertion: should not be reached at /vagrant/mono/mono/metadata/domain.c:470

0009:err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.
Thanks in advance for the help

jkfloris
Level 6
Level 6
Posts: 654
Joined: Thu Aug 14, 2014 10:10 am

Re: Debug Error: WinMor

Post by jkfloris » Sun Dec 30, 2018 1:10 pm

Could you try to use plain Wine, without PlayOnLinux?

Create a new 32-bit wine-prefix and install dotnet20 with winetricks

Code: Select all

WINEPREFIX=~/winmor WINEARCH=win32 winetricks -q dotnet20
Copy the "Winmor_TNC_install_1-5-11-0" directory to "~/winmor/drive_c/"
(I used Winmor_TNC_install_1-5-11-0 from https://downloads.winlink.org/WINMOR%20 ... 5-11-0.zip )


Run Winmor

Code: Select all

cd ~/winmor/drive_c/Winmor_TNC_install_1-5-11-0
WINEPREFIX=~/winmor wine "WINMOR TNC.exe"

MythX
Level 1
Level 1
Posts: 8
Joined: Sun Dec 30, 2018 10:31 am

Re: Debug Error: WinMor

Post by MythX » Sun Dec 30, 2018 1:42 pm

Awesome, thanks. It appears to be working.

I'm seeing this error show up a lot:
ERROR: ld.so: object '/usr/lib/x86_64-linux-gnu/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

I'm not sure if it's a problem, but it's quite repetitive.

Thanks again for the assist.

MythX
Level 1
Level 1
Posts: 8
Joined: Sun Dec 30, 2018 10:31 am

Re: Debug Error: WinMor

Post by MythX » Sun Dec 30, 2018 10:38 pm

In case anyone stumbles across my error message above, here's the a link to the page that helped me solve it:

https://thomasmodeneis.wordpress.com/20 ... e-ignored/

Solution was simply to install package: gtk3-nocsd

Thanks again to jkfloris for helping me solve my other issues.

Jason

Locked