Unable to write files on gvfs-smb share

Questions about Wine on Linux
Post Reply
BS2018
Newbie
Newbie
Posts: 1
Joined: Wed May 02, 2018 12:15 pm

Unable to write files on gvfs-smb share

Post by BS2018 » Wed May 02, 2018 12:35 pm

Hello,

I would like to read and write files on a SMB share with an application running under Wine.
For this, I mounted the SMB-Share using a gvfs-enabled filemanager. Now my application under Wine can read the files on the share, but it cannot write to them. Native Linux applications are however able to write to the share using the same file paths.

Is there something I may have missed?
Has anybody else experienced similar difficulties and overcome them?

To reproduce, mount a SMB share via an gvfs-enabled filemanager.
Then, open the Wine notepad.exe and try to open a text file preexisting on the SMB share.
Add some changes and try to save them.

Thanks in advance for any help,

BS2018

User avatar
Bob Wya
Level 12
Level 12
Posts: 2831
Joined: Sat Oct 16, 2010 7:40 pm
Location: Scotland
Contact:

Re: Unable to write files on gvfs-smb share

Post by Bob Wya » Wed May 02, 2018 5:34 pm

BS2018 wrote:
Is there something I may have missed?
Has anybody else experienced similar difficulties and overcome them?
I don't think smbmount style fuse mounts will work very well with Wine.
I've tried in the paste and it was a PITA.
Also you cannot loop-mount iso images on this filesystem.
Personally I don't even have the net-fs/smbnetfs installed (on my Plasma 5 Gentoo setup).

You're better off using:

Code: Select all

mount -t cifs ...
as this uses the kernel module to mount the external filesystem, rather than fuse - so gives much better performance.
It also supports loop-mounting iso images.
In my experience Wine works pretty well with cifs mounts...

It's easy enough to generate systemd automount units for cifs mounts - for shares you regularly want to connect to.
If you interested I can dig out the syntax for setting this up...

Though personally I tend to prefer nfs / sshfs mounts for my NAS box (I rarely use samba personally - except when I really have to!)

Bob

Post Reply