Regression help

Open forum for end-user questions about Wine. Before asking questions, check out the Wiki as a first step.
Forum Rules
Locked
jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

Regression help

Post by jwong » Wed Aug 17, 2011 2:31 pm

I am having problems getting my app to run under wine-git so that I may perform my regression.

Here is the output when I run wine-git/wine:

Code: Select all

Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:systray:initialize_systray Could not create tray window
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-ai.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-avi.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-bmp.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-chm.xml
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
wine: Unhandled exception 0x40000015 at address 0x525bd9 (thread 0009), starting debugger...
err:menubuilder:write_freedesktop_association_entry error writing association file "/Users/jason/.local/share/applications/wine-extension-chm.desktop"
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-cpl.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-css.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-dib.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-dll.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-eps.xml
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-gif.xml
err:menubuilder:write_freedesktop_association_entry error writing association file "/Users/jason/.local/share/applications/wine-extension-gif.desktop"
err:menubuilder:write_freedesktop_mime_type_entry error writing file /Users/jason/.local/share/mime/packages/x-wine-extension-gz.xml
err:menubuilder:write_freedesktop_association_entry error writing association file "/Users/jason/.local/share/applications/wine-extension-hlp.desktop"
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
err:x11drv:process_attach failed to load libX11.6.dylib: dlopen(libX11.6.dylib, 266): image not found
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
...
I presume this is because I do not have the font libraries loaded for wine-git. Under normal Wine directory everything works fine. I verified the font type libraries are loaded via macports. So the question is how do I get wine-got to find the font libs? Or how do I download the font libs into wine-git? Or I am completely looking at the wrong thing and my application isnt running for some other reason?

Thanks

jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

Post by jwong » Wed Aug 17, 2011 4:40 pm

I should have also noted I am running on OS X and I got wine to install and run was via MacPorts.

oiaohm
Level 8
Level 8
Posts: 1020
Joined: Fri Feb 29, 2008 2:54 am

Post by oiaohm » Wed Aug 17, 2011 7:13 pm

jwong I am sorry the odd of this being a regression is low. I suspect something is wrong with your system or build.

Because what should be system provided libraries are not showing up. Ie freetype and X11 are requirements to run Wine and wine cannot find them this is why its not working.

Maybe talking to MacPorts people they might be able to tell you what you have missed installing. This is my highest suspect.

jjmckenzie
Moderator
Moderator
Posts: 1153
Joined: Wed Apr 27, 2011 11:01 pm

Regression help

Post by jjmckenzie » Wed Aug 17, 2011 8:29 pm

On 8/17/11 5:13 PM, oiaohm wrote:
jwong I am sorry the odd of this being a regression is low. I suspect something is wrong with your system or build.
oiaohm:

JWONG needs to set his PATH to include where Freetype is installed.
MacPorts should do this.

Also the path to the X11 libraries needs to be added to an environment
variable called DYLD_FALLBACK_LIBRARY_PATH. I don't know and cannot
determine from the posting which X11 (Apple's or XQuartz ) and which
version of MacOSX is being used, so the answer for this is pending a
reply with this.

James

doh123
Level 8
Level 8
Posts: 1227
Joined: Tue Jul 14, 2009 1:21 pm

Post by doh123 » Wed Aug 17, 2011 9:15 pm

So what I'm reading from this.. the others seem to maybe have misunderstood... is that you are trying to compile Wine by hand now because you are doing regression testing which you cannot do ... not because this error your seeing is a regression.

Since you built with Macports before... you cannot build the same way, and just trying to compile like normal, what you see is going to happen because it doesn't know where to find the right libraries... you'll have to set some variables before building so it knows what to do.

I think this will work for you... or might need to be slightly modified. I'm guessing on this because i do Wine builds through the stuff I have set up in Wineskin... so I haven't actually tested doing this in a looong time. You might not need to set the gcc/g++ compiler versions and let it use default as well... If you are not using XQuartz built in Macports oyu might have to add some stuff for that path as well, this is assuming you've built everything else Wine needs in Macports (which you should of if you ever installed Wine in Macports)

Code: Select all

export DYLD_FALLBACK_LIBRARY_PATH="/opt/local/lib"
export CC="gcc-4.2"
export CXX="g++-4.2"
export CPPFLAGS="-I/opt/local/include"
export CFLAGS="-arch i386 -m32 -O2 ${CPPFLAGS}"
export CXXFLAGS="$CFLAGS"
export LDFLAGS="-L/opt/local/lib"
after those settings, try to build Wine from scratch again like normal... where it installs by default into /usr/local then you can run it from there instead of the /opt/local version that Macports installed.

jwong
Level 2
Level 2
Posts: 25
Joined: Thu Feb 17, 2011 4:58 pm
Location: US

Post by jwong » Thu Aug 18, 2011 1:31 pm

Thanks everyone for you help. Setting

DYLD_FALLBACK_LIBRARY_PATH="/usr/X11/lib:/usr/lib"

fixed the problem. I am now able to perform my regression testing.

Locked