WineHQ
Wine Forums

Board index » WineHQ » Wine Help




 Page 1 of 1 [ 12 posts ] 



 
Author Message
 Post Posted: Thu Jun 19, 2008 7:41 am 
 
Wine List,

Just looking for ideas, here's my system configuration:

Gentoo Linux 2.4.24
ALSA built as modules
Creative Labs X-Fi 1.18 Driver with a few modifications per
http://gentoo-wiki.com/HARDWARE_Creative_Labs_X-Fi

Game I'm trying to get sound working on is WoW 2.4

winecfg shows no OSS or ALSA mixers, and none show up in the game either.

Now I know, the first thing you're about to tell me is that the X-Fi drivers
are junk. What I'm trying to understand is why every other sound program on
the system works well with it, but Wine won't recognize it at all. Maybe a
clue is that the X-Fi driver doesn't provide the legacy OSS interface?

You tell me...

--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Thu Jun 19, 2008 4:11 pm 
Offline
Moderator
Moderator

Joined: Sat Feb 23, 2008 2:29 pm
Posts: 6605
Jason Weisberger wrote:
Wine List,

Just looking for ideas, here's my system configuration:

Gentoo Linux 2.4.24
ALSA built as modules
Creative Labs X-Fi 1.18 Driver with a few modifications per
http://gentoo-wiki.com/HARDWARE_Creative_Labs_X-Fi

Game I'm trying to get sound working on is WoW 2.4

winecfg shows no OSS or ALSA mixers, and none show up in the game either.


Run winecfg, go to audio tab, exit winecfg. Post complete terminal output here.


Top 
 Post Posted: Thu Jun 19, 2008 4:42 pm 
 
jbdubbs@jbdubbspc ~ $ winecfg
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
jbdubbs@jbdubbspc ~ $

On Thu, Jun 19, 2008 at 5:11 PM, vitamin <wineforum-user@winehq.org> wrote:

Quote:
Jason Weisberger wrote:
Quote:
Wine List,

Just looking for ideas, here's my system configuration:

Gentoo Linux 2.4.24
ALSA built as modules
Creative Labs X-Fi 1.18 Driver with a few modifications per
http://gentoo-wiki.com/HARDWARE_Creative_Labs_X-Fi

Game I'm trying to get sound working on is WoW 2.4

winecfg shows no OSS or ALSA mixers, and none show up in the game either.


Run winecfg, go to audio tab, exit winecfg. Post complete terminal output
here.








--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Fri Jun 20, 2008 8:31 am 
Offline
Moderator
Moderator

Joined: Sat Feb 23, 2008 2:29 pm
Posts: 6605
Jason Weisberger wrote:
jbdubbs@jbdubbspc ~ $ winecfg
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
jbdubbs@jbdubbspc ~ $


Dunno, please file a bug report.


Top 
 Post Posted: Fri Jun 20, 2008 7:24 pm 
 
Will do.

On Fri, Jun 20, 2008 at 9:31 AM, vitamin <wineforum-user@winehq.org> wrote:

Quote:
Jason Weisberger wrote:
Quote:
jbdubbs@jbdubbspc ~ $ winecfg
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
jbdubbs@jbdubbspc ~ $


Dunno, please file a bug report.








--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Tue Jun 24, 2008 3:03 am 
Offline
Newbie
Newbie

Joined: Tue Jun 24, 2008 2:56 am
Posts: 1
Location: Dorset, England
Had the same problem trying to run Baldur's Gate.
Tracked to the problem down to a crashed instance of the game. After killing that I the game worked just fine.
Try
$ pgrep WOW
or whatever the *.exe is called to find the process id then
$ kill xxxx


Top 
 Post Posted: Tue Jun 24, 2008 7:21 pm 
 
Unfortunately this has persisted between reboots as well as several
different kernel and wine compilations with various settings.

On Tue, Jun 24, 2008 at 4:03 AM, thunktone <wineforum-user@winehq.org>
wrote:

Quote:
Had the same problem trying to run Baldur's Gate.
Tracked to the problem down to a crashed instance of the game. After
killing that I the game worked just fine.
Try
$ pgrep WOW
or whatever the *.exe is called to find the process id then
$ kill xxxx








--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Sat Jun 28, 2008 7:04 pm 
 
Just want to add a little more information to see if there are any other
ideas out there:

I've been playing around and realized that it might have something to do
with snd-usb-audio

My usb mic isn't loading into the alsa section of winecfg as well as my
X-Fi. The X-Fi drivers require the usb-audio module, so maybe it's all just
related to that.

Here's the errors I get on the command line now:

jbdubbs@jbdubbspc ~ $ winecfg
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such
file or directory
fixme:mixer:ALSA_MixerInit No master control found on AK5370 ,
disabling mixer

So, if the mixer on the usb mic gets disabled, does that affect how it looks
at all sound cards requiring snd-usb-audio?

I have 3 sound cards running right now, 0 is the X-Fi, 1 is intel hda audio
which works well, 2 is the usb mic.

Neither the mic or the x-fi show up at all in winecfg, but work completely
in any other application on the system using alsa.

On Tue, Jun 24, 2008 at 8:20 PM, Jason Weisberger <jbdubbs@gmail.com> wrote:

Quote:
Unfortunately this has persisted between reboots as well as several
different kernel and wine compilations with various settings.


On Tue, Jun 24, 2008 at 4:03 AM, thunktone <wineforum-user@winehq.org>
wrote:

Quote:
Had the same problem trying to run Baldur's Gate.
Tracked to the problem down to a crashed instance of the game. After
killing that I the game worked just fine.
Try
$ pgrep WOW
or whatever the *.exe is called to find the process id then
$ kill xxxx








--
Jason Weisberger
jbdubbs@gmail.com




--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Sat Jun 28, 2008 7:07 pm 
 
Here's something else my console just spewed:

fixme:wave:ALSA_ComputeCaps Device has a minimum of 2 channels
fixme:wave:ALSA_ComputeCaps Device has a minimum of 2 channels
fixme:wave:ALSA_ComputeCaps Device has a minimum of 2 channels
fixme:wave:ALSA_ComputeCaps Device has a minimum of 2 channels
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post Posted: Sat Jun 28, 2008 9:46 pm 
Offline
Moderator
Moderator

Joined: Sat Feb 23, 2008 2:29 pm
Posts: 6605
Jason Weisberger wrote:
I have 3 sound cards running right now, 0 is the X-Fi, 1 is intel hda audio
which works well, 2 is the usb mic.


You should have started from this. By default Wine uses only one ALSA card. You have to explicitly tell Wine to look for / use other cards.
See http://wiki.winehq.org/UsefulRegistryKeys (Alsa Driver section) for more details.


Top 
 Post Posted: Sun Jun 29, 2008 11:11 am 
 
You are the man, sir.

My config works now as follows:

/etc/asound.conf:

pcm.xfi {
type hw
card 0
device 0
}

ctl.xfi {
type hw
card 0
device 0
}

pcm.usbmic {
type hw
card 2
device 0
}

ctl.usbmic {
type hw
card 2
device 0
}

pcm.hda {
type hw
card 1
device 0
}

ctl.hda {
type hw
card 1
device 0
}


My registry settings:

AutoScanCards = N
AutoScanDevices = N
DeviceCount = 3
DevicePCM1= xfi
DevicePCM2 = usbmic
DevicePCM3 = hda
UseDirectHW = Y



On Sat, Jun 28, 2008 at 10:46 PM, vitamin <wineforum-user@winehq.org> wrote:

Quote:
Jason Weisberger wrote:
Quote:
I have 3 sound cards running right now, 0 is the X-Fi, 1 is intel hda
audio
Quote:
which works well, 2 is the usb mic.


You should have started from this. By default Wine uses only one ALSA card.
You have to explicitly tell Wine to look for / use other cards.
See http://wiki.winehq.org/UsefulRegistryKeys (Alsa Driver section) for
more details.








--
Jason Weisberger
jbdubbs@gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.winehq.org/pipermail/wine-us ... chment.htm


Top 
 Post subject: worked
 Post Posted: Sun Jun 29, 2008 2:30 pm 
Offline
Newbie
Newbie

Joined: Sun Jun 29, 2008 2:22 pm
Posts: 3
Thanks for posting the followup. I didn't even have a /etc/asound.conf but after adding the card 0 entries there along with some regedit settings, the wine sound test now works.

EDIT: more info
Debian SID, Creative X-Fi extreme gamer

Useful x-fi beta driver compile info -> http://technostuff.blogspot.com/2008/04 ... beta2.html
had to use this with kernel 2.6.24 so it doesn't only apply to 2.6.25


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 12 posts ] 




Board index » WineHQ » Wine Help


Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: