WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 10 posts ] 



 
Author Message
 Post Posted: Wed Apr 24, 2013 3:14 pm 
Offline
Level 2
Level 2

Joined: Sun Mar 17, 2013 7:23 am
Posts: 16
Hello, I have another problem.
Maybe you heard about this new game. Dead Island Riptide works fine, except sound. When I run it from the terminal, there are few fixme errors:
Code:
$ wine DeadIslandGame_x86_rwdi.exe
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:thread:SetThreadIdealProcessor (0xfffffffe): stub
fixme:thread:SetThreadIdealProcessor (0x170): stub
fixme:thread:SetThreadIdealProcessor (0x174): stub
fixme:thread:SetThreadIdealProcessor (0x178): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x33e4a4,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
err:ole:CoGetClassObject class {5a508685-a254-4fba-9b82-9a24b00306af} not registered
err:ole:CoGetClassObject no class object {5a508685-a254-4fba-9b82-9a24b00306af} could be created for context 0x1
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:wmvcore:WMCreateReader ((nil), 1, 0x450573c): stub
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:userenv:RegisterGPNotification 0x1d8 0
fixme:userenv:RegisterGPNotification 0x1dc 1
Backtrace:
        (No symbol) [0x026B69A0]
Backtrace:
        (No symbol) [0x026B69A0]
Backtrace:
        (No symbol) [0x026B69A0]
Backtrace:
        (No symbol) [0x026B69A0]
fixme:nls:GetGeoInfoW -1 4 0x33bf30 3 0
fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
fixme:win:EnumDisplayDevicesW ((null),0,0x33bab0,0x00000000), stub!
fixme:advapi:RegisterTraceGuidsW (0x3118140, 0x3850b60, {3dada31d-19ef-4dc1-b345-037927193422}, 1, 0x37e04b8, (null), (null), 0x3850b78,): stub
fixme:advapi:CreateRestrictedToken (0x2f0, 0x2, 7, 0x1978c000, 20, 0x4250690, 1, 0x42bc848, 0x1792dcb8): stub
fixme:ntdll:NtCreateJobObject stub: 0x1792e20c 1f001f <null>
fixme:ntdll:NtSetInformationJobObject stub: 0xdead 9 0x1792e238 112
fixme:ntdll:NtSetInformationJobObject stub: 0xdead 4 0x1792e234 4
fixme:advapi:CreateProcessAsUserW 0x2f8 L"WebView\\berkelium.exe" L"\"WebView\\berkelium.exe\" --type=renderer --lang=en-US --channel=8.04237780.18573128 /prefetch:3" (nil) (nil) 0 0x0100040c (nil) (null) 0x1792e0b8 0x1792e0a0 - semi- stub
fixme:ntdll:NtAssignProcessToJobObject stub: 0xdead 0x300
fixme:d3d:wined3d_swapchain_set_gamma_ramp Ignoring flags 0x1.
fixme:wmvcore:WMCreateReader ((nil), 1, 0x1a9feeac): stub
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.

Computer specs:
intel core i3-3220 (3.3Ghz), 8GB DDR3 1600Mhz, Nvidia geforce GTX460SE

Thanks for any help.


Top 
 Post Posted: Wed Apr 24, 2013 3:33 pm 
Offline
Level 3
Level 3
User avatar

Joined: Tue Oct 23, 2012 6:22 am
Posts: 78
Try to install DX Jun redist. It might be helpful.


Top 
 Post Posted: Thu Apr 25, 2013 2:54 am 
Offline
Level 2
Level 2

Joined: Sun Mar 17, 2013 7:23 am
Posts: 16
Still same :/ I also installed allcodecs, where is dirac, ffdshow, icodecs etc. and still no sound... :( Please someone help me :?


Top 
 Post Posted: Thu Apr 25, 2013 8:33 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 8356
Wine version? If it's not the latest development release, upgrade.

There's no AppDB entry for Dead Island: Riptide; however, there are two old test reports for Dead Island that say
Quote:
had to edit audio.src file and change the API to aOpenAL to make the sound work.

and
Quote:
Edit the audio.src file found in /dl/out/Settings and set the API variable to aXACT, so the sound will work.

so you might want to try those settings in the audio.src file.
http://appdb.winehq.org/objectManager.p ... &iId=24484


Top 
 Post Posted: Thu Apr 25, 2013 4:28 pm 
Offline
Level 2
Level 2

Joined: Sun Mar 17, 2013 7:23 am
Posts: 16
dimesio wrote:
Wine version? If it's not the latest development release, upgrade.

Forget to wrote that: 1.5.28 , okay I'll update.
dimesio wrote:
There's no AppDB entry for Dead Island: Riptide; however, there are two old test reports for Dead Island that say
Quote:
had to edit audio.src file and change the API to aOpenAL to make the sound work.

and
Quote:
Edit the audio.src file found in /dl/out/Settings and set the API variable to aXACT, so the sound will work.

I'll take a look, but sound in Dead Island works just fine. Riptide is only game without sound.

Thanks for help dimesio, I'll post another reply to tell you if it works or not.


Top 
 Post Posted: Thu Apr 25, 2013 4:45 pm 
Offline
Level 2
Level 2

Joined: Sun Mar 17, 2013 7:23 am
Posts: 16
fine, I tried editing audio.src and updating wine... Also i checked and installed redists, that are located in game folder/redist. Still no sound :/


Top 
 Post Posted: Thu Apr 25, 2013 6:07 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 8356
Try winetricks wmp10.


Top 
 Post Posted: Fri Apr 26, 2013 6:12 am 
Offline
Level 2
Level 2

Joined: Sun Mar 17, 2013 7:23 am
Posts: 16
dimesio wrote:
Try winetricks wmp10.

Installed, still no sound. I also tried it with 32bit wineprefix...
This game is really new, so maybe it will work when they release any patch... But what if, this is only game with these problems? :?


Top 
 Post Posted: Fri Apr 26, 2013 8:21 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 8356
File a bug.


Top 
 Post Posted: Thu May 02, 2013 10:50 am 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 8356
FYI, someone submitted an AppDB entry for Dead Island Riptide. They rated it gold; you might want to take a look at their test report. http://appdb.winehq.org/objectManager.p ... &iId=28103


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 10 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 11 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: