WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 2 posts ] 



 
Author Message
 Post Posted: Sun Jan 27, 2013 9:42 am 
Offline
Newbie
Newbie

Joined: Sun Jan 27, 2013 9:15 am
Posts: 2
Hello all,

I am trying to run Guild Wars 2 via Wine, it is playable, but you have to play hide and seek with the login text fields.

Here is a picture of what my screen looks like.

http://play3r.ca/pics/GW2.png

This is what I see after I manage to login.

http://play3r.ca/pics/out.ogv

Terminal Output:

Code:
wine Gw2.exe "-useoldlauncher"
fixme:heap:HeapSetInformation 0x1d00000 0 0x32fd98 4
fixme:process:SetProcessDEPPolicy (1): stub
fixme:process:GetLogicalProcessorInformation (0x32f294,0x32f8c0): stub
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd0c): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd34,0x3530dd0c): stub
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd14): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd3c,0x3530dd14): stub
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd08): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd30,0x3530dd08): stub
fixme:winsock:WS_getsockopt WS_SO_CONNECT_TIME - faking results
fixme:win:EnumDisplayDevicesW ((null),0,0x35300f14,0x00000000), stub!
err:ole:COMPOBJ_DllList_Add couldn't load in-process dll L"C:\\windows\\system32\\dxdiagn.dll"
err:ole:CoGetClassObject no class object {a65b8071-3bfe-4213-9a5b-491da4461ca7} could be created for context 0x1
fixme:win:EnumDisplayDevicesW ((null),0,0x35300c64,0x00000000), stub!
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table
fixme:imm:ImmDisableTextFrameService Stub
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x4002a 0x00000000
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x3530116c, uiNumDevices=1, cbSize=12) stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0x3842e9b8): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x35300a5c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x35300d94,0x00000000), stub!
fixme:d3d:state_zfunc D3DCMP_NOTEQUAL and D3DCMP_EQUAL do not work correctly yet.


FYI: wine Gw2.exe "-useoldlauncher" nor wine Gw2.exe -useoldlauncher worked, it still loaded with the same launcher

System Specs

OS: Mint 14 64Bit

Wine Version is: wine-1.4.1

CPU: AMD Phenom(tm) II X6 1055T Processor
MB: Manufacturer: Gigabyte Technology Co., Ltd. Product Name: GA-990XA-UD3
RAM 8GB DDR3
Video Card: Nvidia GeForce 450 GTX

Umm when i do, sudo dmidecode -t slot i get this, and it should be showing my video card info, right?

Code:
Handle 0x0023, DMI type 9, 13 bytes
System Slot Information
   Designation: PCI Express x16
   Type: x16 PCI Express
   Current Usage: Unknown
   Length: Other
   ID: 0
   Characteristics:
      3.3 V is provided


Other info is, I have d3d_9 installed, after that didn't do anything to help, I installed Dx9, overkill, but that didn't do anything.

Thanks for the help! Need anymore info just ask.


Top 
 Post Posted: Mon Jan 28, 2013 1:22 pm 
Offline
Newbie
Newbie

Joined: Sun Jan 27, 2013 9:15 am
Posts: 2
So, I have gotten a lil farther, I fixed the missing DLL's... just never had them added :oops: .

Now the Terminal output looks like this, screen is still black, but now nothing is click able.

Code:
fixme:heap:HeapSetInformation 0x1d00000 0 0x32fd98 4
fixme:process:SetProcessDEPPolicy (1): stub
fixme:process:GetLogicalProcessorInformation (0x32f294,0x32f8c0): stub
fixme:gameux:GameExplorerImpl_VerifyAccess (0x191d30, L"Z:\\home\\ryan\\Guild Wars 2\\Gw2.exe", 0x32f628)
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd0c): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd34,0x3530dd0c): stub
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd14): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd3c,0x3530dd14): stub
fixme:process:GetLogicalProcessorInformation ((nil),0x3530dd08): stub
fixme:process:GetLogicalProcessorInformation (0x3530dd30,0x3530dd08): stub
fixme:winsock:WS_getsockopt WS_SO_CONNECT_TIME - faking results
fixme:win:EnumDisplayDevicesW ((null),0,0x35300f14,0x00000000), stub!
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:wbemprox:wbem_locator_ConnectServer 0x1967e8, L"\\\\.\\root\\cimv2", (null), (null), (null), 0x00000000, (null), (nil), 0x35b091b4)
fixme:dsound:IKsPrivatePropertySetImpl_Get unsupported property: {f2957840-260c-11d1-a4d8-00c04fc28aca}
fixme:win:EnumDisplayDevicesW ((null),0,0x352fb7c0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x352fb478,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x352fb7c0,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x352fbc90,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x352fb928,0x00000000), stub!
fixme:ddraw:ddraw7_Initialize Ignoring guid {67685559-3106-11d0-b971-00aa00342f9f}.
fixme:d3d:debug_d3dformat Unrecognized 0x434f5441 (as fourcc: ATOC) WINED3DFORMAT!
fixme:d3d:wined3d_get_format Can't find format unrecognized (0x434f5441) in the format lookup table
fixme:msctf:ThreadMgrSource_AdviseSink (0x195948) Unhandled Sink: {ea1ea136-19df-11d7-a6d2-00065b84435c}
fixme:imm:ImmDisableTextFrameService Stub
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x10005c 0x00000000
fixme:win:RegisterRawInputDevices (pRawInputDevices=0x3530116c, uiNumDevices=1, cbSize=12) stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:avrt:AvSetMmThreadCharacteristicsW (L"Audio",0x3842e9b8): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x35300a5c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x35300d94,0x00000000), stub!


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 2 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 4 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: