WineHQ
Wine Forums

Board index » WineHQ » Wine Help » Linux




 Page 1 of 1 [ 8 posts ] 



 
Author Message
 Post Posted: Sat Oct 22, 2011 12:26 pm 
Offline
Newbie
Newbie

Joined: Sat Oct 22, 2011 11:59 am
Posts: 2
WIne will not run programs for me after updating to Ubuntu 11.10. It just doesnt do anything when I click an .exe. I tried starting a program through a Terminal, it says this:

Code:
huntereb@Huntereb:~/Downloads$ wine DeSmuME.exe
X Error of failed request:  XF86VidModeExtensionDisabled
  Major opcode of failed request:  129 (XFree86-VidModeExtension)
  Minor opcode of failed request:  6 (XF86VidModeGetAllModeLines)
  Serial number of failed request:  110
  Current serial number in output stream:  110
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
X Error of failed request:  XF86VidModeExtensionDisabled
  Major opcode of failed request:  129 (XFree86-VidModeExtension)
  Minor opcode of failed request:  6 (XF86VidModeGetAllModeLines)
  Serial number of failed request:  110
  Current serial number in output stream:  110


What is happening? I've installed all of the versions on the Ubuntu Software Center, the same thing. The lines above were taken from Wine 1.3.30. I've installed it through Terminal and not just the Software Center as well, still nothing.

So if you can help me, thanks! I'm new to Ubuntu so I need as much help as I can get...


Top 
 Post subject:
 Post Posted: Sat Oct 22, 2011 3:45 pm 
Offline
Level 1
Level 1

Joined: Sun Aug 28, 2011 7:46 am
Posts: 7
Wine stopped working for me after upgrading to 11.10( so I downgraded) Try 11.04 distro, the only advice I can give.


Top 
 Post subject:
 Post Posted: Sat Oct 22, 2011 3:48 pm 
Offline
Level 1
Level 1

Joined: Sat Oct 22, 2011 3:25 pm
Posts: 6
Location: Scotland.
Have you ensured that the programs are enabled as "execute as program"?


Top 
 Post Posted: Sat Oct 22, 2011 5:19 pm 
Offline
Moderator
Moderator
User avatar

Joined: Tue Mar 25, 2008 10:30 pm
Posts: 7833
Huntereb wrote:
WIne will not run programs for me after updating to Ubuntu 11.10.

Did you try reinstalling them to a clean wineprefix? Also, don't use 1.3.30; there was a regression in it that caused a lot of apps to crash on start. It's fixed in 1.3.31.


Top 
 Post subject:
 Post Posted: Sat Oct 22, 2011 8:42 pm 
Offline
Level 2
Level 2
User avatar

Joined: Mon Sep 26, 2011 4:08 pm
Posts: 31
Use regedit
Create the key under HK_Current_User\Software\Wine\X11Driver\
new string -> 'UseXVidMode' - 'N'
and see if that helps

http://wiki.winehq.org/UsefulRegistryKeys


Top 
 Post Posted: Sat Oct 22, 2011 9:07 pm 
Offline
Moderator
Moderator

Joined: Wed Apr 27, 2011 11:01 pm
Posts: 1153
On 10/22/11 10:26 AM, Huntereb wrote:
Quote:
WIne will not run programs for me after updating to Ubuntu 11.10. It just doesnt do anything when I click an .exe. I tried starting a program through a Terminal, it says this:


Code:
huntereb@Huntereb:~/Downloads$ wine DeSmuME.exe
X Error of failed request: XF86VidModeExtensionDisabled
Major opcode of failed request: 129 (XFree86-VidModeExtension)
Minor opcode of failed request: 6 (XF86VidModeGetAllModeLines)
Serial number of failed request: 110
Current serial number in output stream: 110
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
X Error of failed request: XF86VidModeExtensionDisabled
Major opcode of failed request: 129 (XFree86-VidModeExtension)
Minor opcode of failed request: 6 (XF86VidModeGetAllModeLines)
Serial number of failed request: 110
Current serial number in output stream: 110




What is happening? I've installed all of the versions on the Ubuntu Software Center, the same thing. The lines above were taken from Wine 1.3.30. I've installed it through Terminal and not just the Software Center as well, still nothing.

This looks like a missing function in your video card drivers. Thus I
would like to get which video card and drivers you are using. If you
are using an nVidia/ATI card please use the proprietary driver as the
noveau driver is missing several essential (to Wine) driver functions.

James


Top 
 Post subject:
 Post Posted: Sat Oct 22, 2011 11:37 pm 
Offline
Newbie
Newbie

Joined: Sat Oct 22, 2011 11:59 am
Posts: 2
I figured it out, I have been trying to open the programs remotely through a VNC program. For some reason, wine doesn't let you open programs from a remote client. I figured this out because I can open programs from my computer not remotely fine. But if you try it through VNC it doesn't do anything. This is strange, I've never seen a program act like this before.

So, does anyone know how to enable opening programs with Wine remotely?

Thanks for the help!


Top 
 Post Posted: Sun Oct 23, 2011 4:39 am 
 
On Sat, 2011-10-22 at 23:37 -0500, Huntereb wrote:
Quote:
I figured it out, I have been trying to open the programs remotely
through a VNC program. For some reason, wine doesn't let you open
programs from a remote client.

Two possible causes:

- VNC isn't a true X-server. It only implements enough of the usual
X11 facilities to handle *nix programs.

- by default it uses XFCE rather than Gnome or KDE. XFCE is fairly
light weight and may not support features that Wine needs.

Quote:
So, does anyone know how to enable opening programs with Wine
remotely?

Enable X11 forwarding for ssh - its disabled by default.
Login over ssh and start the program from the command line.
That works for the small number of programs I need to run under wine.

Or you could try switching VNC to use your usual desktop.


Martin


Top 
Display posts from previous:  Sort by  
 
 Page 1 of 1 [ 8 posts ] 




Board index » WineHQ » Wine Help » Linux


Who is online

Users browsing this forum: No registered users and 2 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: